CTProComply, Where corporate maintenance meets peace of mind

We Can Help

855.316.8940
Mon - Fri 9:00 am to 5:00 pm Eastern Time
- or - We'll get back to you as soon as possible.

Thank you for visiting CTProComply, a Wolters Kluwer company.


We have detected that you are using a browser that connects to our system through an SSL or TLS 1.0/1.1 cryptographic protocol.

To comply with new industry standards, CTProComply will no longer support SSL or TLS 1.0/1.1 after June 15, 2018. To avoid any online service disruptions with CTProComply and other organizations, please upgrade to the latest version of your browser.

 

Find Out About Browser Compatibility


What is SSL and TLS?

Secure Sockets Layer ("SSL") and Transport Layer Security ("TLS") are protocols designed to ensure that data can be securely transported between a web server and a browser using cryptographic algorithms. SSL/TLS ensures that the data transmitted comes from the source it claims to be coming from and has not been compromised by a 3rd party.

Why do I need to upgrade?

Security is the primary reason for upgrading to a browser that support TLS 1.2. The new standards prevents order and payment details or your data, such as your username and password from being exposed to the internet and allow it to be intercepted.

Upgrading will also ensure that you will not experience widespread service disruptions online and in e-commerce environments before or after the June 15, 2018 migration deadline.

What immediate steps should I take?

  • Check if You are Using a Safe Browser

    To confirm that your web broswer is using TLS 1.2, online tools such as Qualys SSL Labs provide an easy way to determine if you're using a secure version of TLS.

  • Talk to Your IT Professional

    If you have confirmed that you are using a web browser that only supports SSL and/or TLS 1.0/1.1, then you should contact your IT administrator or your IT service provider about actions you can take to upgrade your browser to one that provides more security for your online transactions and is compatible with the new standards.

  • More Helpful Information

    There is a resource guide available from the PCI Security Standards Council which provides information on the new security standards.

Is my current browser compatible?

Compatibility Guidelines

Compatibility Chart - SSL and TLS update 2018